Animation Test - any tips?

Post your tutorials and help questions in this forum
Locked
thomas
Posts: 348
Joined: Tue Aug 31, 2010 9:59 am

Animation Test - any tips?

Post by thomas »

Hi all!

I let the PC render out a couple of frames to test an animation. It looks okay, but there are splotches, most visible in the wall to ceiling edge in the top left corner:

https://vimeo.com/145060191

Any ideas on how to get rid of these? I'm using QMC at the moment, with one pass corner path tracing at 50%, and I like the look of the render overall, but I do want to get rid of the splotches.
User avatar
Janusz Biela
Posts: 3265
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Animation Test - any tips?

Post by Janusz Biela »

As you see theses errors (light leaks) are static. It give us information something is wrong with photon map. I suggest shoot render (one frame) in Precomputed mode:
ScreenShot054.png

If you will see "hot photons" , something like that:
K2.png
then you must search where from it is:

- not supported Node - apparently is only one which make for sure that error: Dielectric Node
- somewhere is very strong not physical Light source (LEM)
- If you use HDRi - can be error from "hot pixel" in this map it means some regions of HDRi map generate very strong photons. usually blurring map under Lightwave helps.


To switch OFF Nodes simply use Kray Override plugin:
ScreenShot056.png
ScreenShot056.png (16.1 KiB) Viewed 4190 times



If you can not find where from it is try:
- increase parameter N up to 2000 (here is 50 on image):
ScreenShot055.png
- check is for sure you have Path Passes enable (for extra Path Tracing Photons in corners:
ScreenShot057.png
thomas
Posts: 348
Joined: Tue Aug 31, 2010 9:59 am

Re: Animation Test - any tips?

Post by thomas »

Thanks for the tip! I did a test setting the corner path tracing to 200% - that was already a lot better. I'll let you know what caused the issue.
thomas
Posts: 348
Joined: Tue Aug 31, 2010 9:59 am

Re: Animation Test - any tips?

Post by thomas »

Hi Janusz,

Here's my pre-compute pass, pre-compute without the dielectric vase and pre-compute override:
PreComputed.jpg
PreComputed-No Dielectric.jpg
PreComputed-Override.jpg
It doesn't really look like there's hot photons in there, but the photons just seem to all have a very high contrast. My lighting is an area light for sun, and a luminous skydome.

Setting N higher does also work, but doesn't this smooth out photons too much, reducing the detail?
User avatar
Janusz Biela
Posts: 3265
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Animation Test - any tips?

Post by Janusz Biela »

So do you use Dielectric or not? If yes than forget this Node. This create "hot photons" or "hot GI samples". I am not sure but G. tried to do something with this problem but it seems there in Node is bug and no documentation so better avoid.
I think your size cells is too small also. Personally I use 300 mm in interiors.
If are no errors in Photon Map you can keep parameter N very low (100-200)
thomas
Posts: 348
Joined: Tue Aug 31, 2010 9:59 am

Re: Animation Test - any tips?

Post by thomas »

I am using dielectric in the scene for the glass vase on the green shelf, so yes. But in the second render of the three posted above I replaced the dielectric with a normal simple node-based surface, and the photon map looks almost exactly the same. The third render is Kray override without nodes and the photon map also looks very similar, so I don't think the dielectric vase is causing any issues here.

In general, I'm surprised to see how much contrast is in the photons, for a scene that is fairly clean and uniform in variation of surfaces and lighting. I have raised the number of photons to 20.000.000, and this gives me the following pre-computed result:
PreComputed-MorePhotons.jpg
Naturally the density of photons is much higher, but still with the same high contrast between them.
Rendering with N = 2000 gives this result, which is fairly clean:
N-2000.jpg
That's pretty okay, but it kind of bothers me that it doesn't really fix the issue: it just makes the splotches smaller and blurs them out more - which looks better, but it's not really a fix, it's more a low-pass filter on the error.

Interestingly, after that I reduced the GI resolution from auto to .3m, and re-rendered with 2.000.000 photons (ten times less than the previous render), and it looks great! So thanks Janusz for the tip. Maybe this caused the error: the GI resolution was set to AUTO before, but there was a skydome around the scene. Perhaps this made the dimensions of the scene too big in the auto-setting for GI resolution!

Render with GI-resolution at .3 here:
GI-3.jpg
User avatar
Janusz Biela
Posts: 3265
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Animation Test - any tips?

Post by Janusz Biela »

Just keep the rules:
- no Dielectric (is really giving randomly burning shoot in samples)
- GI resolution manual 300 mm (interiors)
- N=200 (the lower the better)
- Path Passes 1/200% (this is big distance corner but I noticed gives everywhere very accurate photons)
- do not use Precache Blur
Locked