Version confusion with KRAY 2.59

General disscusion about Kray
3dviz
Posts: 6
Joined: Fri Jun 11, 2010 5:12 am

Version confusion with KRAY 2.59

Postby 3dviz » Wed Jun 17, 2015 3:52 am

Hi There,
I'm getting version errors after installing 2.59 in LW 11.6.3.
After installing 2.59 the Kray GUI says 2.2. Also the 'Use KRAY Instances' flag is gone from Plugins tab.

See attached images.
For the sake of testing, Plugins completely removed and deleted from configs before re-installing new versions.
I reinstalled plugin and all Common .lsc's from the download packages.

We seem to be getting inconsistant versioning in LW.

With 2.55 installed:
- GUI version: 'Kray Options (2.5 Build 1223 LSC) (This seems incorrect to me? Should it be 2.55?)
- Plugin version: 'Kray 2.55 for Lightwave 11.6+
Kray_2-55_Install.jpg
2.55 Install


After Installing 2.59:
- GUI version: 'Kray Options (2.2 Build 1224 LSC) (Shouldn't this be 2.59?)
- Plugin version: 'Kray 2.59 for Lightwave 11.6+
Kray_2-59_Install.jpg
2.59 Install


And this is a list of the LSC files that were added from the 'Common' downloaded package for 2.59. Some of these appear quite old, is this correct?
2-59_common.jpg
2.59 Common LSC directory


Thanks,
- Matt

User avatar
Janusz Biela
Posts: 4001
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Version confusion with KRAY 2.59

Postby Janusz Biela » Wed Jun 17, 2015 10:35 am

Is correct. GUI and Render Engine has different numeration. As you see some scripts are very old because is nothing to do with them. Probably K2.59 is pre last version of Kray and history of plugin will finish on version 2.60 (depends from Newtek and G. how long he wants support Kray 2.x in LW).
The most important in number in Kray Render Window. If you have 2.59 it means you have the newest version of Kray.

3dviz
Posts: 6
Joined: Fri Jun 11, 2010 5:12 am

Re: Version confusion with KRAY 2.59

Postby 3dviz » Thu Jun 18, 2015 2:02 am

Ok great. Thanks.
Quick question - I assume the 2.55 'Common' lsc files (UI 2.5) would work Ok with Kray plugin 2.59?

The 2.5 UI has the 'Use KRAY Instances' flag, the 2.2 UI included in the 2.59 package has this removed.
We still maintain some older scenes that use Kray instances instead of Native LW, and this flag is handy for quick proofing.

Regards, - Matt.

User avatar
Janusz Biela
Posts: 4001
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Version confusion with KRAY 2.59

Postby Janusz Biela » Thu Jun 18, 2015 10:23 am

I think you can mix ls scripts but if are problems, please write here and I will post to G.

3dviz
Posts: 6
Joined: Fri Jun 11, 2010 5:12 am

Re: Version confusion with KRAY 2.59

Postby 3dviz » Thu Jun 18, 2015 12:17 pm

Thanks Janusz!


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest