Shader simulator

Post Reply
User avatar
Janusz Biela
Posts: 4010
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Shader simulator

Post by Janusz Biela » Thu Jul 06, 2017 4:04 pm

Maybe somebody can render this in K2 with reasonable time? :mrgreen:
transparency.7z
(13.64 KiB) Downloaded 97 times

Here is my K3:
K3_tester.png
K3_tester.png (210.16 KiB) Viewed 1973 times

User avatar
promity
Posts: 236
Joined: Sat Feb 24, 2007 4:49 pm
Location: Russia
Contact:

Re: Shader simulator

Post by promity » Fri Jul 07, 2017 2:08 pm

I decided to compare the render speed between K3 and Arnolz (Maya) being skeptical of K3. However, I was wrong.
K3 - 2m 13s
K3_RC1_001.jpg
Arnold (12AA) - 3m 23s
Maya_arnold_12AA.jpg
Arnold (9AA, 4Diffuse sampling) - 7m 35s
Maya_arnold_9AA_7_35.jpg

User avatar
Janusz Biela
Posts: 4010
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Shader simulator

Post by Janusz Biela » Fri Jul 07, 2017 2:30 pm

btw
This new importance option has some small speed issues (not correct balance). G. research now "problem".
It should be at least 50% faster. Also after VCM will be again faster....and after optimization again faster.
The scene is very interesting: deep recurse everywhere. Photon path has so big journey from light source that only a few hits camera.
In Arnold you can see missing transparency photons (almost black shadow behind glass). And for clean render you have to wait around 20-30 min.
Maybe you setup wrong render?

...and you can not compare modern PM engine with anything, is just impossible. Arnold (and others unbiased systems) must calculate billions of paths when Kray3 needs only a couple of thousand.

...still believe in interpolation.... :!:

User avatar
promity
Posts: 236
Joined: Sat Feb 24, 2007 4:49 pm
Location: Russia
Contact:

Re: Shader simulator

Post by promity » Fri Jul 07, 2017 2:41 pm

almost black shadow behind glass

I have long tried to find an explanation for this, until I started K3 in Path tracing mode. And I got exactly the same shadows.
K3_RC1_PT_001.jpg

User avatar
Janusz Biela
Posts: 4010
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Shader simulator

Post by Janusz Biela » Fri Jul 07, 2017 3:31 pm

Check settings. Because here in PT I got same effect:
K3_tester.png
K3_tester.png (212.54 KiB) Viewed 1933 times

User avatar
promity
Posts: 236
Joined: Sat Feb 24, 2007 4:49 pm
Location: Russia
Contact:

Re: Shader simulator

Post by promity » Fri Jul 07, 2017 3:41 pm

It strange becouse i only changed Diffuse Model.

User avatar
Janusz Biela
Posts: 4010
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Shader simulator

Post by Janusz Biela » Fri Jul 07, 2017 6:42 pm

promity wrote:It strange becouse i only changed Diffuse Model.
I will test this scene more. Maybe is something wrong with GI management .

Post Reply