K3.03 official release

User avatar
Janusz Biela
Posts: 4012
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: K3.03 official release

Post by Janusz Biela » Thu May 02, 2019 3:11 pm

AVLKray wrote:
cruisermori wrote:Hi Janusz. How is your experience with displacement and render speed? I tested a simple plane and it slows down render dramatically (from seconds to minutes). LW 2015
Can you tell me where to find the displacement shader.
Under surface shaders there is no displacement shader here? (LW11)

OK try in this way: Add all plugins again by selecting everything what you have in K3 folder.
Restart LW.

User avatar
Janusz Biela
Posts: 4012
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: K3.03 official release

Post by Janusz Biela » Thu May 02, 2019 3:16 pm

AVLKray wrote:I had to revert back to 3.02, have had some serious issues with 3.03 under 11.6.3 Win 7 Pro.
Strange things happening for no apparent reason. Been having constant LW crashes not only during rendertime, couldn't work for more than 10 minutes without a crash. Even my file manager Q-Dir (been using for 10 years) started crashing every 10 min or so. Couldn't figure out what was going on. Looked almost like malware/virus or so. Was about to re-install LW.
Until I noticed that copying surfaces from or to the preset shelf or to other surfaces persitantly crashed LW BUT only after the first K3.03 render. Before first render everything is fine, after first render LW starts crashing all the time.
So I reverted back to 3.02, now i have been working several hours and everything is fine again....
OK it seems there is problem with K3 plugin for LW11.....
Apparently I have only LW2015 so I can not confirm anything.
I suggest (if this is possible install LW2015 for a couple of months) and after that when we polish K3 jump to LW2019 - that`s will be our destination plugin of K3. Since LW2019 is very developed software (with really good features and SDK) with exporter to Unreal Engine - from now this is future and target for K3.

ZodiaQ
Posts: 361
Joined: Mon Mar 25, 2013 4:52 pm

Re: K3.03 official release

Post by ZodiaQ » Thu May 02, 2019 3:53 pm

Janusz Biela wrote:
AVLKray wrote:
cruisermori wrote:Hi Janusz. How is your experience with displacement and render speed? I tested a simple plane and it slows down render dramatically (from seconds to minutes). LW 2015
Can you tell me where to find the displacement shader.
Under surface shaders there is no displacement shader here? (LW11)

OK try in this way: Add all plugins again by selecting everything what you have in K3 folder.
Restart LW.
Worked thx!

ZodiaQ
Posts: 361
Joined: Mon Mar 25, 2013 4:52 pm

Re: K3.03 official release

Post by ZodiaQ » Thu May 02, 2019 3:55 pm

Janusz Biela wrote:
AVLKray wrote:I had to revert back to 3.02, have had some serious issues with 3.03 under 11.6.3 Win 7 Pro.
Strange things happening for no apparent reason. Been having constant LW crashes not only during rendertime, couldn't work for more than 10 minutes without a crash. Even my file manager Q-Dir (been using for 10 years) started crashing every 10 min or so. Couldn't figure out what was going on. Looked almost like malware/virus or so. Was about to re-install LW.
Until I noticed that copying surfaces from or to the preset shelf or to other surfaces persitantly crashed LW BUT only after the first K3.03 render. Before first render everything is fine, after first render LW starts crashing all the time.
So I reverted back to 3.02, now i have been working several hours and everything is fine again....
OK it seems there is problem with K3 plugin for LW11.....
Apparently I have only LW2015 so I can not confirm anything.
I suggest (if this is possible install LW2015 for a couple of months) and after that when we polish K3 jump to LW2019 - that`s will be our destination plugin of K3. Since LW2019 is very developed software (with really good features and SDK) with exporter to Unreal Engine - from now this is future and target for K3.
Unfortunately I skipped 2015. Will wait for K3 for 2019 to be stable.
Last edited by ZodiaQ on Thu May 02, 2019 4:50 pm, edited 2 times in total.

User avatar
Janusz Biela
Posts: 4012
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: K3.03 official release

Post by Janusz Biela » Thu May 02, 2019 4:24 pm

AVLKray wrote: Unfortunately I skipped 2015. Will wait for K3 for 2019 to be stable.

...I think this is the best option from now. I also want forget old LW since LW2019 offers really good stability , new features, new surface system and bridge to Unreal Engine.

ZodiaQ
Posts: 361
Joined: Mon Mar 25, 2013 4:52 pm

Re: K3.03 official release

Post by ZodiaQ » Thu May 02, 2019 4:50 pm

You can always try in LW2015 :
Copy material A in Surface editor and Paste it to material B. so far it works. Paste again to material B. Still ok. (you can copy and paste as much as you want)
Now try the same after starting and cancelling K3 render (just need to run a second). Copy or Paste surface will crash LW

User avatar
Janusz Biela
Posts: 4012
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: K3.03 official release

Post by Janusz Biela » Thu May 02, 2019 7:42 pm

AVLKray wrote:You can always try in LW2015 :
Copy material A in Surface editor and Paste it to material B. so far it works. Paste again to material B. Still ok. (you can copy and paste as much as you want)
Now try the same after starting and cancelling K3 render (just need to run a second). Copy or Paste surface will crash LW
Cannot reproduce this bug. Probably is something "special" in scene or surface. I need your scene.

ZodiaQ
Posts: 361
Joined: Mon Mar 25, 2013 4:52 pm

Re: K3.03 official release

Post by ZodiaQ » Fri May 03, 2019 9:39 am

Scene and video :
surface-copy-paste-crash.mp4
(1.7 MiB) Downloaded 37 times
export.zip
(1.3 MiB) Downloaded 23 times
gives 100% crash here

Win 7 Pro x64

User avatar
Janusz Biela
Posts: 4012
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: K3.03 official release

Post by Janusz Biela » Fri May 03, 2019 10:21 am

Thanks!
Posted on bug tracker.
Actually this bug is very rare (good hunt!) because some of them appear ONLY in special circumstances :D
These are the worst...some of them I hunt 1-3 months! Is enough change something little in scene or just delete something small and bug disappear.

User avatar
Keraressi Abdelkarim
Posts: 830
Joined: Sun Jan 24, 2010 4:44 pm

Re: K3.03 official release

Post by Keraressi Abdelkarim » Sat May 11, 2019 5:44 am

Janusz Biela wrote:Thanks!
Posted on bug tracker.
Actually this bug is very rare (good hunt!) because some of them appear ONLY in special circumstances :D
These are the worst...some of them I hunt 1-3 months! Is enough change something little in scene or just delete something small and bug disappear.

it happen to me i didnt want to signal it because it will get remived in others release. when i have displacement in surface and when cop for pasting it crash lw 2015 it bug coming from displacement thats why i remove that k3 version and i use previous one wich work better stable.

Post Reply