Lost in Demo-Version 2.61 - HELP

Post your tutorials and help questions in this forum
User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sat Sep 02, 2017 9:09 pm

Hi there ;-)

I have been playing around with the Demo Version 2.61 of Kray.
At first, it seemed like I would get it nailed but now I'm totally lost.

My goal was to do a test animation but if flickers like mad and
also changes color etc. I'm getting a red tint on the walls and
I have no clue why... Lightwave crashes after rendering 10 frames,
and I can't find out why. I don't even know if my object is modelled
correctly for Kray... maybe I need a different modelling technique?

Can someone tell me what I'm doing wrong, please?

I've uploaded the scene file so you guys could play around with it.

Let me know what you guys think... I would be very thankful for
some help.

Cheers,
StevenR.
Attachments
TheOffice.zip
(1.36 MiB) Downloaded 59 times

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 11:10 am

Hi

Procedures:

Bake GI with STEP every 20 frame (you do not need more frames, is enough every 20-40 frames)
ScreenShot073.png
ScreenShot073.png (30.64 KiB) Viewed 2273 times

ScreenShot074.png
ScreenShot074.png (12.7 KiB) Viewed 2273 times


-------------------------------------------------------------


After Bake GI you switch render to normal mode with ONLY one pass and Step frame 1
Render:


ScreenShot076.png
ScreenShot076.png (30.6 KiB) Viewed 2273 times

ScreenShot075.png
ScreenShot075.png (32.32 KiB) Viewed 2273 times

ScreenShot077.png
ScreenShot077.png (11.72 KiB) Viewed 2273 times



---------------------------------------------------------------------
Scene ready for Bake (include ready animation in slow motion - 100 frames test done in total 4 min)
Scene has my best universal settings for interiors

TheOffice.7z
(3.89 MiB) Downloaded 59 times

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 11:11 am

btw
Soon Demo Kray 3.0.

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sun Sep 03, 2017 11:42 am

Thank you so much for the response.
Your Scene look great!!! :shock:

You wrote:
After Bake GI you switch render to normal mode with ONLY one pass and Step frame 1 Render

with "ONLY one Pass" you mean the Final Gather?

But to achieve the Baking, you use the same settings on every Tab, except Final Gather with 2 passes?

Cheers,
Steven R.

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sun Sep 03, 2017 12:30 pm

Hi there Janusz

I've been playing around some more... here is what I came up with... see attached JPEG
And I also posted my settings...

I'm still not 100% sure whit the baking stuff. So, I leave all the settings in the Kray Tabs the same,
FinalGather with 2 passes, bake out the Scene with frame steps 20, change to frame step 1 and
FinalGather to 1...?

But this is REALLY FUN and the images look cool :D

Cheers,
Steven R.
Attachments
Screen Shot 2017-09-03 at 12.21.35.png
Screen Shot 2017-09-03 at 12.21.35.png (83.05 KiB) Viewed 2270 times
Screen Shot 2017-09-03 at 12.21.33.png
Screen Shot 2017-09-03 at 12.21.33.png (71.66 KiB) Viewed 2270 times
Screen Shot 2017-09-03 at 12.21.32.png
Screen Shot 2017-09-03 at 12.21.32.png (84 KiB) Viewed 2270 times
Screen Shot 2017-09-03 at 12.21.30.png
Screen Shot 2017-09-03 at 12.21.30.png (82.7 KiB) Viewed 2270 times
Screen Shot 2017-09-03 at 12.21.28.png
Screen Shot 2017-09-03 at 12.21.28.png (76.87 KiB) Viewed 2270 times
TestOffice_0129.jpg

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 12:30 pm

LightwaveSteven wrote:Thank you so much for the response.
Your Scene look great!!! :shock:

You wrote:
After Bake GI you switch render to normal mode with ONLY one pass and Step frame 1 Render

with "ONLY one Pass" you mean the Final Gather?

But to achieve the Baking, you use the same settings on every Tab, except Final Gather with 2 passes?

Cheers,
Steven R.


Yes

- When you BAKE GI you need full quality render.
- Bake GI doesn`t need reflection and Anti-Aliasing - why you see white render during bake.
- Bake GI needs only a few frames (every 20-40 frame) because camera make very little movement and new region appearing during moving are just a few percent of whole scene. If you put in Bake mode frame step ONE you will waste time (Kray will not find so many new GI samples) and you will start search sample which already founded. Of course when camera move very very fast you need smaller step. For interior is enough 20-40. For this scene I think step 40 is ok.
- When you finish BAKE you must switch Kray to LOAD option with ONLY ONE PASS (you do not need calculate samples again because they already founded)
- You can render this scene on other computers:
* computer 01 - frames 0-100
* computer 02 - frames 101-200
* etc
Just copy GI file or load GI file over netwotk.
BAKE is ready - so nothing change in scene. Only is calculated AA and reflection/blur.
- You can stop render and continue later (final rendering after bake)
- GI file can be huge (2-4 Gigabytes) depends from complexity of scene.

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 12:32 pm

Distribution of Photon Mapping in Kray is one of the best. There is no way to get flickering.

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sun Sep 03, 2017 12:38 pm

Thank you SO much, Janusz! :D

You are a HUGE help

What I forgot to mention:
in MY scene, the camera will not be moving, just the window blinds come down slowly
for 20 Seconds, and then they turn to close and the room becomes almost dark.

Would that make any difference in the set up?

Cheers,
Steven R.

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 2:06 pm

LightwaveSteven wrote:Thank you SO much, Janusz! :D

You are a HUGE help

What I forgot to mention:
in MY scene, the camera will not be moving, just the window blinds come down slowly
for 20 Seconds, and then they turn to close and the room becomes almost dark.

Would that make any difference in the set up?

Cheers,
Steven R.


This is the worst scenario for Photon Mapping (generally in renderings).
You have two choices:
- use Path Tracing (it will take years to render)
- use Time Interpolation in Photon Mapping

Time Interpolation create blending between frames to reduce flickering. Because we MUST shoot for each frame separate photon solution.
Every frame has different Photon Map - it means: flickering.
We must shoot for each frame separate Photon Map because you have moving objects in scene (blinds going down so every second is darker and darker, every frame has different Photon Map according to situation from blinds position.

You must render each frame like single frame - so there is no possibilities to speed up. You can not stop rendering. You can not share over network. You must render it on single computer.

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 2:12 pm

Here scene with Time Interpolation. Scene is setup for final quality (I render without AA and 2 passes):

TheOffice_Time_Interpolation.7z
(4.15 MiB) Downloaded 60 times

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sun Sep 03, 2017 3:00 pm

Thanks a lot for the help.

The funny thing is that Lightwave always crashes and I can't really tell what is causing it.
I can't reproduce it, it just seems to come up every now and then. I sometimes just make a
change to ONE setting and start a Render Frame and it crashes...

...could it be that I'm running Demo Version or did I miss something crucial on installation?

Are there any log files that gat saved and I could send to you for inspection?

I have an official version of LW 2015.3 running on MAC OSX Sierra,
2x2.93 GHz 6-Core Intel Xeon, with 12GBs of RAM

Cheers
Steven R.

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sun Sep 03, 2017 3:13 pm

What's really weird its that when I start a render, I can see "Unable to read current scene file".....????....."Trying original scene file"

WHY??? I don't get it.... my scene works perfect...

Greetings,
Steven R.
Attachments
Screen Shot 2017-09-03 at 15.10.25.png
Screen Shot 2017-09-03 at 15.10.25.png (86.87 KiB) Viewed 2265 times

User avatar
Janusz Biela
Posts: 3998
Joined: Mon Mar 13, 2006 10:39 am
Location: Finland
Contact:

Re: Lost in Demo-Version 2.61 - HELP

Postby Janusz Biela » Sun Sep 03, 2017 6:42 pm

Try on another computer (MAC)

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Sun Sep 03, 2017 7:38 pm

:) :) :) :)

Unfortunately, I only have ONE Mac....

Maybe I could de-install and install again. Maybe I did something wrong, or not so optimal.
Why only after 10 frames...??? Could it be the 2015.3-Version of LW, could it be my Mac,
could it be the Trail-Version of Kray???

NO IDEA...

Are there settings in LW that are known to interfere with Kray and can cause crashes?

For now I think my only option is to render stills and fade them together in Adobe Premiere...

Cheers,
Steven R

User avatar
LightwaveSteven
Posts: 13
Joined: Mon May 31, 2010 11:37 pm
Location: Switzerland

Re: Lost in Demo-Version 2.61 - HELP

Postby LightwaveSteven » Mon Sep 04, 2017 7:42 am

Good morning

Hey, I was thinking: I'm using a plant in the corner which has UVs... I think I read in your manuals that Kray doesn't like UVs..... is that still true?

Maybe that is causing LW to crash...

I also checked Geometry and found holes in the polys, so I fixed them.... but LW and/or Kray still crashes....

Maybe there are other objects with holes and non-planar polys which need fixing...

What do you think?

I'm gonna render that scene you gave me... that seemed to work on your machine... so like that I can circle it around a bit more and find the problem.

Cheers and thanks A LOT... I have learned a lot in the past 48 hours and it's pretty obvious that Kray will be first choice!

The results are ultra-cool and nice!

Cheers,
Steven


Return to “Help and Tutorials”

Who is online

Users browsing this forum: No registered users and 3 guests